First Name
Email
Message subject
Enter your message


* Required Field

PalmForm Technical Requirements

Software Recommended Minimum

More information

Joomla! 1.5.x, Joomla! 1.7.x and Joomla! 2.5x The latest version 1.5.1 http://www.joomla.org
Mozilla Firefox The latest version 3.0 http://www.mozilla.com

- PalmForm backend works with the browsers Mozilla Firefox 3.0 or later and Internet Explorer 8 or later with small bugs. PalmForm frontend works with all browsers.

- AJAX and the communication between the browser and the server should work properly.

Joomla! Form Builder Quick Start

Buy PalmForm

Buy PalmForm


Joomla! 2.5.x